Pull in darkstat-3.0.718
[darkstat-debian] / debian / patches / FixHURDsFTBS.patch
1 Description: Use the correct macro for OS X
2  The OS X fix use the macro __MACH__, this catch up on Hurd, so 
3  better use __APPLE__
4 Author: RenĂ© Mayorga <rmayorga@debian.org>
5 ---
6 This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
7 --- a/now.c
8 +++ b/now.c
9 @@ -23,7 +23,7 @@
10  #include <string.h>
11  #include <time.h>
12  
13 -#ifdef __MACH__
14 +#ifdef __APPLE__
15  /* Fake up clock_gettime() on OS X. */
16  # include <sys/time.h>
17  # include <inttypes.h>