Pull in darkstat-3.0.718
[darkstat-debian] / debian / patches / FixHURDsFTBS.patch
diff --git a/debian/patches/FixHURDsFTBS.patch b/debian/patches/FixHURDsFTBS.patch
new file mode 100644 (file)
index 0000000..1a05c77
--- /dev/null
@@ -0,0 +1,17 @@
+Description: Use the correct macro for OS X
+ The OS X fix use the macro __MACH__, this catch up on Hurd, so 
+ better use __APPLE__
+Author: RenĂ© Mayorga <rmayorga@debian.org>
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/now.c
++++ b/now.c
+@@ -23,7 +23,7 @@
+ #include <string.h>
+ #include <time.h>
+-#ifdef __MACH__
++#ifdef __APPLE__
+ /* Fake up clock_gettime() on OS X. */
+ # include <sys/time.h>
+ # include <inttypes.h>