Update portability notes.
[darkstat] / configure.ac
index a82b6cf..11ee1bb 100644 (file)
@@ -1,6 +1,6 @@
 # Need at least 2.64 for PACKAGE_URL
 AC_PREREQ([2.64])
-AC_INIT(darkstat, 3.0.0-git, , , http://unix4lyfe.org/darkstat/)
+AC_INIT(darkstat, 3.0.0-git, , , https://unix4lyfe.org/darkstat/)
 AC_CONFIG_SRCDIR([darkstat.c])
 AC_CONFIG_HEADER([config.h])
 
@@ -17,6 +17,9 @@ AC_DEFINE_UNQUOTED(PRIVDROP_USER, "$_pdu", [User to privdrop to.])
 AC_PROG_INSTALL
 AC_PROG_CC
 
+# Compiler's language features.
+AC_C_RESTRICT
+
 m4_pattern_allow([^AM_DEFAULT_VERBOSITY$])
 AC_ARG_ENABLE([silent-rules],
 [  --enable-silent-rules          less verbose build output (undo: 'make V=1')
@@ -106,10 +109,9 @@ $RULE
 I can't link to zlib.  You really can't have a modern
 operating system without zlib.
 
-If you are using a package-based operating system (like
-something with RPMs), see if there is a zlib-devel package
-that you can install, to provide the zlib headers and
-libraries.
+On Debian or a derivative, try: sudo apt-get install zlib1g-dev
+
+On an RPM system, see if there is a zlib-devel package.
 
 $RULE
 END