Use the host compiler for build tool c-ify.
[darkstat-debian] / debian / rules
index 3eb88a3..e63e77a 100755 (executable)
@@ -8,6 +8,8 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 DPKG_EXPORT_BUILDFLAGS = 1
 include /usr/share/dpkg/buildflags.mk
+-include /usr/share/dpkg/buildtools.mk
+CC_FOR_BUILD ?= cc
 
 configure: configure-stamp
 configure-stamp: 
@@ -22,7 +24,7 @@ build-indep: build
 
 build-stamp: configure-stamp
        dh_testdir
-       $(MAKE)
+       $(MAKE) HOSTCC=$(CC_FOR_BUILD)
        touch $@
 
 clean: